请问Dapp安装流程出现的问题



  • 按照官方流程安装测试Dapp,结果报错。ubuntu 16.0.4版
    /home/ubuntu/asch/node_modules/sodium/install.js:287
    throw new Error(cmdLine + ' exited with code ' + code);
    ^

    Error: make libsodium exited with code 2
    at ChildProcess.<anonymous> (/home/ubuntu/asch/node_modules/sodium/install.js:287:19)
    at ChildProcess.emit (events.js:180:13)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! sodium@2.0.3 preinstall: node install.js --preinstall
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the sodium@2.0.3 preinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/ubuntu/.npm/_logs/2018-03-28T03_57_12_551Z-debug.log



  • Mac上也是这里错误,十分奇怪这个到底是什么原因



  • @by371 said in 请问Dapp安装流程出现的问题:

    libtool is required, but wasn't found on this system

    win10系统下安装,还是在这个sodium安装时报错。不明白是哪出了问题



  • /home/ubuntu/.nvm/versions/node/v9.9.0/bin/asch-cli -> /home/ubuntu/.nvm/versions/node/v9.9.0/lib/node_modules/asch-cli/bin/asch-cli

    • asch-cli@1.3.8
      updated 1 package in 3.898s
      ubuntu@VM-0-4-ubuntu:~/asch$ npm i

    sodium@2.0.3 preinstall /home/ubuntu/asch/node_modules/sodium
    node install.js --preinstall

    Static libsodium was not found at /home/ubuntu/asch/node_modules/sodium/deps/build/lib/libsodium so compiling libsodium from source.
    libtool is required, but wasn't found on this system
    Makefile:61: recipe for target 'libsodium' failed
    make: *** [libsodium] Error 1
    /home/ubuntu/asch/node_modules/sodium/install.js:287
    throw new Error(cmdLine + ' exited with code ' + code);
    ^

    Error: make libsodium exited with code 2
    at ChildProcess.<anonymous> (/home/ubuntu/asch/node_modules/sodium/install.js:287:19)
    at ChildProcess.emit (events.js:180:13)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:209:12)
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! sodium@2.0.3 preinstall: node install.js --preinstall
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the sodium@2.0.3 preinstall script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/ubuntu/.npm/_logs/2018-03-28T04_12_20_005Z-debug.log
    看了以下,貌似不支持ubuntu


Log in to reply
 

Looks like your connection to Asch was lost, please wait while we try to reconnect.